package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi).*(dog)`)
var str = `dog dog cat fish
dog dog cat fish
dog dog dog cat fish
dog fish
dog dog gone it
dog dog woof`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}