using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div((.+?(?=<\/div>)|.+?(?=<div>))|(?R))*<\/div>";
string input = @"Text outside any div
<div id=""my_id""> bla bla
<div>
bla bla bla
<div style=""some style here"">
lalalalala
</div>
</div>
I'm trapped in a div!
</div>
more text outside divs
<div>more divs here!
<div id=""justbeingannoying"">radiohead rules</div>
</div>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}