re = /<div((.+?(?=<\/div>)|.+?(?=<div>))|(?R))*<\/div>/i
str = 'Text outside any div
<div id="my_id"> bla bla
<div>
bla bla bla
<div style="some style here">
lalalalala
</div>
</div>
I\'m trapped in a div!
</div>
more text outside divs
<div>more divs here!
<div id="justbeingannoying">radiohead rules</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end