const regex = /<div((.+?(?=<\/div>)|.+?(?=<div>))|(?R))*<\/div>/sig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div((.+?(?=<\\\/div>)|.+?(?=<div>))|(?R))*<\\\/div>', 'sig')
const str = `Text outside any div
<div id="my_id"> bla bla
<div>
bla bla bla
<div style="some style here">
lalalalala
</div>
</div>
I'm trapped in a div!
</div>
more text outside divs
<div>more divs here!
<div id="justbeingannoying">radiohead rules</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}