import re
regex = re.compile(r"<div((.+?(?=<\/div>)|.+?(?=<div>))|(?R))*<\/div>", flags=re.DOTALL | re.IGNORECASE)
test_str = ("Text outside any div\n"
"<div id=\"my_id\"> bla bla\n"
" <div>\n"
" bla bla bla\n"
" <div style=\"some style here\">\n"
" lalalalala\n"
" </div>\n"
" </div>\n"
" I'm trapped in a div!\n"
"</div>\n"
"more text outside divs\n\n"
"<div>more divs here!\n"
" <div id=\"justbeingannoying\">radiohead rules</div>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")