#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^!\s(?P<StartDate>\S+) +(?P<StartTime>\S+)(?: +(?P<EndDate>\S+)(?: +(?P<EndTime>\S+))?)?"
Local $sString = "----------------------------------------------" & @CRLF & _
"! 16/Oct/2020 10:11:14 12/Nov/2020 11:21:32" & @CRLF & _
"!----------------------------------------------" & @CRLF & _
"! 17/Oct/2020 10:11:14" & @CRLF & _
"!----------------------------------------------" & @CRLF & _
"! 18/Oct/2020 11:00:00 21/Oct/2020 12:00:00" & @CRLF & _
"!----------------------------------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")