using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^!\s(?P<StartDate>\S+) +(?P<StartTime>\S+)(?: +(?P<EndDate>\S+)(?: +(?P<EndTime>\S+))?)?";
string input = @"----------------------------------------------
! 16/Oct/2020 10:11:14 12/Nov/2020 11:21:32
!----------------------------------------------
! 17/Oct/2020 10:11:14
!----------------------------------------------
! 18/Oct/2020 11:00:00 21/Oct/2020 12:00:00
!----------------------------------------------";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}