use strict;
my $str = '----------------------------------------------
! 16/Oct/2020 10:11:14 12/Nov/2020 11:21:32
!----------------------------------------------
! 17/Oct/2020 10:11:14
!----------------------------------------------
! 18/Oct/2020 11:00:00 21/Oct/2020 12:00:00
!----------------------------------------------';
my $regex = qr/^!\s(?P<StartDate>\S+) +(?P<StartTime>\S+)(?: +(?P<EndDate>\S+)(?: +(?P<EndTime>\S+))?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}