package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^!\s(?P<StartDate>\S+) +(?P<StartTime>\S+)(?: +(?P<EndDate>\S+)(?: +(?P<EndTime>\S+))?)?`)
var str = `----------------------------------------------
! 16/Oct/2020 10:11:14 12/Nov/2020 11:21:32
!----------------------------------------------
! 17/Oct/2020 10:11:14
!----------------------------------------------
! 18/Oct/2020 11:00:00 21/Oct/2020 12:00:00
!----------------------------------------------`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}