package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ims)(<[^>]*) (data-(\S+)="((?:\\.|[^"\\])*)")`)
var str = `<span title="use a" data-type="test">Some Content</label>
<span data-test="abc" title="use b">Some Other Content</label>
<p data-type="">test</p>
<a href="https://www.google.com" data-ogsc="">MAP</a>
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}