const regex = /(<[^>]*) (data-(\S+)="((?:\\.|[^"\\])*)")/gimus;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*) (data-(\\S+)="((?:\\\\.|[^"\\\\])*)")', 'gimus')
const str = `<span title="use a" data-type="test">Some Content</label>
<span data-test="abc" title="use b">Some Other Content</label>
<p data-type="">test</p>
<a href="https://www.google.com" data-ogsc="">MAP</a>
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);