import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^>]*) (data-(\\S+)=\"((?:\\\\.|[^\"\\\\])*)\")";
final String string = "<span title=\"use a\" data-type=\"test\">Some Content</label>\n"
+ "<span data-test=\"abc\" title=\"use b\">Some Other Content</label>\n"
+ "<p data-type=\"\">test</p>\n"
+ "<a href=\"https://www.google.com\" data-ogsc=\"\">MAP</a>\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}