// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?imus)(<[^>]*) (data-(\S+)="((?:\\.|[^"\\])*)")"#).unwrap();
let string = "<span title=\"use a\" data-type=\"test\">Some Content</label>
<span data-test=\"abc\" title=\"use b\">Some Other Content</label>
<p data-type=\"\">test</p>
<a href=\"https://www.google.com\" data-ogsc=\"\">MAP</a>
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}