package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(20[12]\d)(0[1-9]|1[012])(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3])[0-5]\d[0-5]\d-\w+\.sql$`)
var str = `DYO_STUS_20150120T143814.xml`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}