const regex = /^(20[12]\d)(0[1-9]|1[012])(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3])[0-5]\d[0-5]\d-\w+\.sql$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(20[12]\\d)(0[1-9]|1[012])(0[1-9]|[12]\\d|3[01])_([01]\\d|2[0-3])[0-5]\\d[0-5]\\d-\\w+\\.sql$', '')
const str = `DYO_STUS_20150120T143814.xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}