re = /^(20[12]\d)(0[1-9]|1[012])(0[1-9]|[12]\d|3[01])_([01]\d|2[0-3])[0-5]\d[0-5]\d-\w+\.sql$/
str = 'DYO_STUS_20150120T143814.xml'
# Print the match result
str.match(re) do |match|
puts match.to_s
end