import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(20[12]\\d)(0[1-9]|1[012])(0[1-9]|[12]\\d|3[01])_([01]\\d|2[0-3])[0-5]\\d[0-5]\\d-\\w+\\.sql$";
final String string = "DYO_STUS_20150120T143814.xml";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}