using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^""]*)""$";
string input = @"\\My_Machine\root\cimv2:Win32_UserAccount.Domain=""My_Machine"",Name=""Administrator""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}