re = /([^"]*)"$/
str = '\\\\My_Machine\\root\\cimv2:Win32_UserAccount.Domain="My_Machine",Name="Administrator"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end