$re = '/([^"]*)"$/';
$str = '\\\\My_Machine\\root\\cimv2:Win32_UserAccount.Domain="My_Machine",Name="Administrator"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);