using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)tag(.*?)/tag(?=.*\bOnly catch above this)";
string input = @"tagcatch 1/tag
tagcatch 2/tag
tagcatch 3/tag
Only catch above this
tagcatch 4/tag
tagcatch 5/tag
tagcatch 6/tag";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}