import re
regex = re.compile(r"(?s)tag(.*?)/tag(?=.*\bOnly catch above this)")
test_str = ("tagcatch 1/tag\n"
"tagcatch 2/tag\n"
"tagcatch 3/tag\n"
"Only catch above this\n"
"tagcatch 4/tag\n"
"tagcatch 5/tag\n"
"tagcatch 6/tag")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")