re = /(?s)tag(.*?)\/tag(?=.*\bOnly catch above this)/
str = 'tagcatch 1/tag
tagcatch 2/tag
tagcatch 3/tag
Only catch above this
tagcatch 4/tag
tagcatch 5/tag
tagcatch 6/tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end