const regex = /foo(?=bar)|(?<=bar)bar/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo(?=bar)|(?<=bar)bar', 'gm')
const str = `barfoobarbarfoo`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);