use strict;
my $str = 'barfoobarbarfoo';
my $regex = qr/foo(?=bar)|(?<=bar)bar/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";