$re = '/foo(?=bar)|(?<=bar)bar/m';
$str = 'barfoobarbarfoo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;