import re
regex = re.compile(r"foo(?=bar)|(?<=bar)bar", flags=re.MULTILINE)
test_str = "barfoobarbarfoo"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)