#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{4})\d(?=\d{4})|\d(?=\d{4})"
Local $sString = "123467671234" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)