const regex = /^(\d{4})\d(?=\d{4})|\d(?=\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})\\d(?=\\d{4})|\\d(?=\\d{4})', 'gm')
const str = `123467671234
`;
const subst = `$1X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);