import re
regex = re.compile(r"^(\d{4})\d(?=\d{4})|\d(?=\d{4})", flags=re.MULTILINE)
test_str = ("123467671234\n\n")
subst = "$1X"
result = regex.sub(subst, test_str)
if result:
print(result)