import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bmodule\\b[^\\\\;]+)\\\\([^[]+)\\[(\\d+)\\][^;]+\\2\\[(\\d+)\\]";
final String string = "module modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9); nonmodule modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9)";
final String subst = "\\1\\2[\\3:\\4]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}