use strict;
my $str = 'module modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9); nonmodule modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9)';
my $regex = qr/(\bmodule\b[^\\;]+)\\([^[]+)\[(\d+)\][^;]+\2\[(\d+)\]/mp;
my $subst = '\\1\\2[\\3:\\4]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";