const regex = new RegExp('(\\bmodule\\b[^\\\\;]+)\\\\([^[]+)\\[(\\d+)\\][^;]+\\2\\[(\\d+)\\]', 'gm')
const str = `module modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9); nonmodule modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9)`;
const subst = `\1\2[\3:\4]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);