# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bmodule\b[^\\;]+)\\([^[]+)\[(\d+)\][^;]+\2\[(\d+)\]"
test_str = "module modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9); nonmodule modulename(wire1, wire2, \\wire3[0], \\wire3[1], \\wire3[2], wire4, wire5,wire6, wire7, \\wire8[0], wire9)"
subst = "\\1\\2[\\3:\\4]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.