#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m);(?!(([^"]*"){2})*[^"]*$)"
Local $sString = "106;"LORDAL La Manicure, ser;um do manuzi, wzrost, 5 ml";301*04*334;46;"loksx-la-mainusttej-wzroxst-5-ml";"";"";19.51220;"";"";"thumb23_9671ds359.png""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")