$re = '/;(?!(([^"]*"){2})*[^"]*$)/m';
$str = '106;"LORDAL La Manicure, ser;um do manuzi, wzrost, 5 ml";301*04*334;46;"loksx-la-mainusttej-wzroxst-5-ml";"";"";19.51220;"";"";"thumb23_9671ds359.png"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);