re = /;(?!(([^"]*"){2})*[^"]*$)/m
str = '106;"LORDAL La Manicure, ser;um do manuzi, wzrost, 5 ml";301*04*334;46;"loksx-la-mainusttej-wzroxst-5-ml";"";"";19.51220;"";"";"thumb23_9671ds359.png"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end