using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?!(([^""]*""){2})*[^""]*$)";
string input = @"106;""LORDAL La Manicure, ser;um do manuzi, wzrost, 5 ml"";301*04*334;46;""loksx-la-mainusttej-wzroxst-5-ml"";"";"";19.51220;"";"";""thumb23_9671ds359.png""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}