#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(\d)([.-]?\1)+$)(\d{3}[-.]?\d{3}[-.]?\d{4})"
Local $sString = "1111111111" & @CRLF & _
"111-111-1111" & @CRLF & _
"111.111.1111" & @CRLF & _
"" & @CRLF & _
"112.111.1111" & @CRLF & _
"111.112.1111" & @CRLF & _
"111.111.1112" & @CRLF & _
"" & @CRLF & _
"767-789-9876" & @CRLF & _
"7677899876"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")