using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(\d)([.-]?\1)+$)(\d{3}[-.]?\d{3}[-.]?\d{4})";
string input = @"1111111111
111-111-1111
111.111.1111
112.111.1111
111.112.1111
111.111.1112
767-789-9876
7677899876";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}