re = /^(?!(\d)([.-]?\1)+$)(\d{3}[-.]?\d{3}[-.]?\d{4})/m
str = '1111111111
111-111-1111
111.111.1111
112.111.1111
111.112.1111
111.111.1112
767-789-9876
7677899876'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end