import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(\\d)([.-]?\\1)+$)(\\d{3}[-.]?\\d{3}[-.]?\\d{4})";
final String string = "1111111111\n"
+ "111-111-1111\n"
+ "111.111.1111\n\n"
+ "112.111.1111\n"
+ "111.112.1111\n"
+ "111.111.1112\n\n"
+ "767-789-9876\n"
+ "7677899876";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}