use strict;
my $str = 'ThisisAtestForchEck,Match IngwithPosition';
my $regex = qr/([A-Z][a-z]*(?: [A-Z][a-z]*)*)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";