$re = '/([A-Z][a-z]*(?: [A-Z][a-z]*)*)/m';
$str = 'ThisisAtestForchEck,Match IngwithPosition';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;