// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z][a-z]*(?: [A-Z][a-z]*)*)").unwrap();
let string = "ThisisAtestForchEck,Match IngwithPosition";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}