re = /([A-Z][a-z]*(?: [A-Z][a-z]*)*)/m
str = 'ThisisAtestForchEck,Match IngwithPosition'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result