# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^(),]*(\((?:[^()]|(?1))*\))[^(),]*(*SKIP)(*F)|,/\n/gm;t' <<< "alpha, (beta,cat), delta (echo,frank(gamma,(hotel)),india), (jack, kilo), larry"