package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^(),]*(\((?:[^()]|(?1))*\))[^(),]*(*SKIP)(*F)|,`)
var str = `alpha, (beta,cat), delta (echo,frank(gamma,(hotel)),india), (jack, kilo), larry`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}