import Foundation
let pattern = #"[^(),]*(\((?:[^()]|(?1))*\))[^(),]*(*SKIP)(*F)|,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"alpha, (beta,cat), delta (echo,frank(gamma,(hotel)),india), (jack, kilo), larry"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)