use strict;
my $str = 'alpha, (beta,cat), delta (echo,frank(gamma,(hotel)),india), (jack, kilo), larry';
my $regex = qr/[^(),]*(\((?:[^()]|(?1))*\))[^(),]*(*SKIP)(*F)|,/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";